Jump to content

Recommended Posts

Hi, 

I installed both NextCloud (Apache74) with Apache & PHP 74 but I got error when trying to setup then nextcloud.

image.png.fcd12f4c9dbb70a01604d1cb9407ce12.png

I got the same error after I enabled the zip module.  

Has anyone had similar problem?

Following was the output for listing modules loaded on PHP.

[/share/CE_CACHEDEV1_DATA/.qpkg/Apache74] # /share/CE_CACHEDEV1_DATA/.qpkg/Apache74/bin/php -m                                 
PHP Warning:  Module 'sodium' already loaded in Unknown on line 0
PHP Warning:  Module 'gmagick' already loaded in Unknown on line 0
PHP Warning:  Module 'grpc' already loaded in Unknown on line 0


amqp
apcu
bcmath
bitset
bz2
calendar
Core
ctype
curl
date
dba
dom
eio
enchant
ev
event
exif
fileinfo
filter
ftp
gd
geoip
gettext
gmagick
gmp
gnupg
grpc
hash
hprose
hrtime
http
iconv
igbinary
imagick
imap
inotify
intl
json
krb5
ldap
libxml
mailparse
mbstring
mcrypt
memcached
mongodb
msgpack
mysqli
mysqlnd
OAuth
odbc
openssl
pcntl
pcre
PDFlib
PDO
pdo_dblib
pdo_mysql
PDO_ODBC
pdo_pgsql
pdo_sqlite
pgsql
Phar
posix
propro
pspell
radius
raphf
readline
redis
Reflection
scrypt
session
shmop
SimpleXML
snmp
soap
sockets
sodium
solr
SPL
sqlite3
standard
swoole
tidy
timezonedb
tokenizer
xattr
xdebug
xml
xmlreader
xmlrpc
xmlwriter
xsl
xxtea
yaml
zip
zlib

[Zend Modules]
Xdebug
 

 

Link to post
Share on other sites
On 1/23/2020 at 11:59 AM, stef61b said:

Bonjour

J'ai exactement le meme problème Apache 74 et Nextcloud 74 . 

image.png.5ce7ec011892701b0363e3cda29fd6d9.png

quelqu'un a t il une solution? 

For me it worked after I added "extension=zip.so" to php.ini in the Apache74 config, and then restarted Apache7.

 

However, there's a next issue I run into: after the install script has run (all db tables have successfully been created) I am redirected to a blank index.php page. When opening up the Nextcloud app it opens the installation page again. 

I don't know how to fix that yet... Anyone?

Link to post
Share on other sites
  • 4 weeks later...
  • 4 weeks later...
  • 3 weeks later...
  • 3 weeks later...

just bought apache 74 and to install this package. after several hours of trying, no luck with installation. 

#1 tried to install with webinterface: install proceeds to blank page ("no response from server"), tried sqlite and mysql : same result

#2 tried to install by commandline: /share/CACHEDEV1_DATA/.qpkg/Apache74/bin/php ./nextcloud/occ maintenance:install --database "mysql" --database-name "Nextcloud74"  --database-user "Nextcloud74" --database-pass "pass" --admin-user "User" --admin-pass "pass" -vvv

error message: "Illegal instruction"

i can see that some tables have been created in phpmyadmin, so connection to mysql should not be the problem.

#3 tried to download nextcloud.zip into the root directory, unpacked it in ./nextcloud and tried #1 and #2 again: same result

so the nextcloud package should not be the problem 

i suspect that apache74 php is just not working with nextcloud as suggested (which actually feels a bit odd, after paying for a package that is based on freeware).

 

any help please?

 

Link to post
Share on other sites

hello there

it's not a white screen, actually the next site (after filling in the configuration-data on the install-landing-page and clicking "install")   does not load at all: grey screen with message "no response from server" in my browser. after trying to install by command line, which also failed,  i am convinced that the issue has to do with apache 7.4's php - it's not just about site-loading and it looks like it is not a permission/certificate error either (tried without https: same result) .

 

Link to post
Share on other sites

Hello 
me on my qnap nextcloud installs and executes perfectly by relying on Qapache . But the version based on Apache 73 or 74 (2.3 or 2.4) is launched and when I launch the configuration procedure, the database (postgres or mariadbb I tried both) is created and my browser arrives after one minute and 20 seconds on a white screen. I warned Qoolbox several months ago and he told me that he was reproducing on one of his qnap but has no solution. 

[Fri Apr 17 16:44:25.449777 2020] [mpm_event:notice] [pid 29136:tid 140604994578240] AH00489: Apache/2.4.43 (Unix) OpenSSL/1.1.1f SVN/1.13.0-dev PHP/7.4.5 configured -- resuming normal operations
[Fri Apr 17 16:44:25.450018 2020] [core:notice] [pid 29136:tid 140604994578240] AH00094: Command line: '/opt/Apache74/bin/httpd -f /share/CACHEDEV1_DATA/.qpkg/NextCloud74/httpd.conf'
[Fri Apr 17 16:45:08.604961 2020] [access_compat:error] [pid 29146:tid 140603329111808] [client 192.168.0.61:44130] AH01797: client denied by server configuration: /share/CACHEDEV1_DATA/.qpkg/NextCloud74/nextcloud/data/htaccesstest.txt
[Fri Apr 17 16:45:33.422175 2020] [access_compat:error] [pid 29148:tid 140603580991232] [client 192.168.0.61:44804] AH01797: client denied by server configuration: /share/CACHEDEV1_DATA/.qpkg/NextCloud74/nextcloud/data/htaccesstest.txt
[Fri Apr 17 16:46:16.618353 2020] [access_compat:error] [pid 29148:tid 140603522242304] [client 192.168.0.61:46274] AH01797: client denied by server configuration: /share/CACHEDEV1_DATA/.qpkg/NextCloud74/nextcloud/data/htaccesstest.txt
[Fri Apr 17 16:47:49.045982 2020] [access_compat:error] [pid 10043:tid 140603704862464] [client 192.168.0.61:50186] AH01797: client denied by server configuration: /share/CACHEDEV1_DATA/.qpkg/NextCloud74/nextcloud/data/htaccesstest.txt
[Fri Apr 17 16:47:49.616676 2020] [core:notice] [pid 29136:tid 140604994578240] AH00052: child pid 29146 exit signal Illegal instruction (4)
[Fri Apr 17 16:47:50.618986 2020] [core:notice] [pid 29136:tid 140604994578240] AH00052: child pid 29148 exit signal Illegal instruction (4)

 

I modified php.ini  like on this  site https://www.howtoforge.com/tutorial/how-to-install-nextcloud-on-debian-10/ but it's KO . 

I hope you find a solution .

Link to post
Share on other sites

yes, it'

s exactly the same for me. i also had a working qapache/nextcloud installation before trying to upgrade to apache 7.4 (in hope of improvements in speed).

1 hour ago, stef61b said:

I warned Qoolbox several months ago and he told me that he was reproducing on one of his qnap but has no solution. 

i am on a ts-251+

1 hour ago, stef61b said:

modified php.ini  like on this  site https://www.howtoforge.com/tutorial/how-to-install-nextcloud-on-debian-10/ but it's KO . 

was  it working for you after that?

 

to be honest, i am a bit lost here. since the command-line-install fails only with the message "illegal instruction" (after creating the database and running for a couple of minutes), there is not much information for troubleshooting.  

Link to post
Share on other sites

I'm not sure how to implement this. They're talking about a nextcloud.conf file that I don't have. I assumed that on QNAP it was the httpd.conf in the nextcloud directory. 
I added Satisfy Any in this file 

DocumentRoot "${WWWPATH}"
<Directory "${WWWPATH}">
    #
    Satisfy Any 
    # Possible values for the Options directive are "None", "All",
    # or any combination of:
    #   Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
    #
    # Note that "MultiViews" must be named *explicitly* --- "Options All"
    # doesn't give it to you.
    #
    # The Options directive is both complicated and important.  Please see
    # http://httpd.apache.org/docs/2.4/mod/core.html#options
    # for more information.
    #
    Options Indexes FollowSymLinks MultiViews
    <IfModule mod_dav.c>
        Dav off
    </IfModule>

    
    #
    # AllowOverride controls what directives may be placed in .htaccess files.
    # It can be "All", "None", or any combination of the keywords:
    #   AllowOverride FileInfo AuthConfig Limit
    #
    AllowOverride All

    #
    # Controls who can get stuff from this server.
    #
    Require all granted

 SetEnv HOME ${WWWPATH}
 SetEnv HTTP_HOME ${WWWPATH}
 Satisfy Any 

</Directory>

 

but it's KO .  :( 

Link to post
Share on other sites
2 hours ago, stef61b said:

bendsch up ? 

what do you mean? i did not make any progress and don't know how to resolve it, i think only the developer can help, but unfortunately he does not seem to read the forums. any idea how to get in touch with him=

Link to post
Share on other sites
il y a une heure, bendsch a dit :

what do you mean? i did not make any progress and don't know how to resolve it, i think only the developer can help, but unfortunately he does not seem to read the forums. any idea how to get in touch with him=

I've asked Qoolbox. But since he's the only one to ask for it, maybe you can send him a message too.

Link to post
Share on other sites

Qoolbox replied to my question and it seems like he resolved the issue. so apparently with the newest version posted above install should be running. i though it would still be interesting for users upgrading vom Nextcloud/Qapache to see Qoolboxes answer: 

added to the config file on last line  :  /share/CACHEDEV1_DATA/.qpkg/NextCloud74/nextcloud/config/config.php

  'hashing_default_password' => true,

config file look like this one after a second setup (tested with sqlite and apache74, but this trick should work for all DB and Apache73)

<?php
$CONFIG = array (
  'instanceid' => 'ocg61wiq87m3',
  'passwordsalt' => 'ydniAQlWFcDG9MMAWzMlK8XkvgLZro',
  'secret' => 'O2DHiLvehj3VCsRPCak+sHUzSUXcJOPnJ9+knoHrN8qYJ5O5',
  'trusted_domains' => 
  array (
    0 => '192.168.0.59:35180',
  ),
  'datadirectory' => '/share/CACHEDEV1_DATA/.qpkg/NextCloud74/nextcloud/data',
  'dbtype' => 'sqlite3',
  'version' => '18.0.4.2',
  'overwrite.cli.url' => 'http://192.168.0.59:35180',
  'hashing_default_password' => true,
);

 

other solution found by user on www.forum-nas.fr

seems that there is bug with PASSWORD_ARGON2I algorithm to generate password. Solution:

comment lines 208, 209, 210 in nextcloud/lib/private/Security/Hasher.php such that they look like:
//if (\defined('PASSWORD_ARGON2I')) {
// $default = PASSWORD_ARGON2I;
//}

I managed to upgrade from my Nextcloud/Qapache to NextCloud74/Apache74 by just copying ".qpkg/NextCloud/nextcloud" to ".qpkg/NextCloud74/nextcloud" (overwrite it) and adding the line "  'hashing_default_password' => true," to ".qpkg/NextcCoud74/nextcloud/conf/config.php" (like described by Qoolbox). Then i copied my server.crt and server.key from  ".qpkg/NextCloud" to ".qpkg/NextCloud74". Last thing i did is changing the https-port in ".qpkg/NextCloud74/NextCloud74/NextCloud74.sh" back to "45083 in order to work with my old config, bookmarks and domain . Then restarted Apache74 and Nextcloud74 and everything worked as expected.

Happy upgrading and many thanx to the developer

Bendsch 

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...