Jump to content

Recommended Posts

Thanks to you and Qoolbox . 

finally I created an ubuntu VM and I followed what you did so well. 
everything is perfect I created two letsencrypt domains one for nextcloud and one for onlyoffice. it works great. 

https://riegers.in/nextcloud-installation-guide-ubuntu-18-04/

https://riegers.in/nextcloud-and-only-office-nginx/

I have an A+ rating on qualys SSL 

et nextcloud ne prend pas toutes les ressources du NAS puisque borné dans la VM 

 

Link to post
Share on other sites
  • 2 weeks later...

trying to make this work together wir QMariaDB (since internal MariaDB is still on 5.xx).

nextcloud can be started but is not reachable, so my guess is, that apache74 tries to connect to the internal MariaDB socket. Any hints where i can point Apache74 and/or Nextcloud74 to /tmp/QMariadDB2.sock 

Link to post
Share on other sites
  • 4 weeks later...
  • 3 weeks later...
  • 2 weeks later...

I am a bit puzzled about the different installers of Nextcloud and Qapache.

I understand that Nextcloud(74) is designed to work with Qapache (74) and
NextCloud(73) is designed to work with Qapache(73)

I have "bought" the plain "nextcloud", but what is that for?
Should I rather "buy" Apache(74) and use the free Nextcloud(74) with it?

Update: I have now found out that the plain nextcloud works direcly on top of the QTS build-in web server. Unfortunately that is still on PHP 7.2.29 which will no longer be supported by nexcloud from V.20+ (I will send a request to QNAP-Support to integrate php 7.4 into next update)

:?: Matthias

Link to post
Share on other sites
  • 3 weeks later...
  • 1 month later...
  • 2 weeks later...
  • 4 weeks later...
  • 4 weeks later...
  • 1 month later...
  • 2 weeks later...
  • 2 weeks later...
  • 1 month later...
  • 3 weeks later...
  • 1 month later...
  • 3 months later...
Le 03/07/2020 à 17:07, MatthiasJ a dit :

I am a bit puzzled about the different installers of Nextcloud and Qapache.

I understand that Nextcloud(74) is designed to work with Qapache (74) and
NextCloud(73) is designed to work with Qapache(73)

I have "bought" the plain "nextcloud", but what is that for?
Should I rather "buy" Apache(74) and use the free Nextcloud(74) with it?

Update: I have now found out that the plain nextcloud works direcly on top of the QTS build-in web server. Unfortunately that is still on PHP 7.2.29 which will no longer be supported by nexcloud from V.20+ (I will send a request to QNAP-Support to integrate php 7.4 into next update)

I have also bought the Qapache module for 1€ and now the plain Nextcloud does not work; it throws an error which says it needs 7.2.30 when in the description, it says it needs 7.2.29.

I would really like to know how this is meant to work as it is.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...