Jump to content

Connexion Iscsi - Plantage Du Nas 659Rp


Recommended Posts

Bonjour,

Je me présente, je m'appelle Erick. Je suis Ingénieur système Windows et je travail actuellement sur la mise en place de clusters à basculement HyperV sur du stockage QNAP en isci.

Je m'incris sur ce forum car sur plusieurs config que j'ai mis en place, j'ai découvert que les qnap (modèle 459 et 469 dernier firmware: 3.7.3...) plantaientt complètement (réponse de l'interface web mais aucun effet sur le NAS) lors de gros accès disque: Création des disques durs virtuels par exemple.

La configuration:

Serveurs: HP Proliant DL380 G7 + iscsi accelerated activé + OS windows 2008 R2 SP1

Réseau: 2 Switchs Dlink DGS 3120 stacké (vlan: iscsi/lan/vm)

Stockage: QNAP 469RP 4x2To en RAid5 (cache désactivé, tous les services non utilisés désactivés)

Le réseau iscsi est dédié: jumbo frame 9000 / flow control activé

L'initiation isci est effectuée via les initiateurs matériels des serveurs Proliant sur trois LUN créés sur le QNAP (quorum et lun VHD). Le MPIO est activé.

Tout semble fonctionner correctement.

Mais j'ai remarqué que lors de la création des disques durs virtuels sur les LUNS, la connection iscsi se coupe et les LUNS ne sont plus connectéés et impossible au serveurs de se reconnecter. Après une visite sur l'interface d'aministration du NAS, le QNAP ne réponds plus et il faut eteindre matériellement le NAS pour que les connexions iscsi fonctionne de nouveau.

J'ai fait les mêmes tests en utilisant l'initiateur iscsi microsoft, le problème ne se produit pas.

J'ai deux config similaires où le problème se produit en utilisant les initiateurs matériels des serveurs.

C'est un vrai casse tête...

J'aimerai savoir si quelqu'un à une expérience similaire avec les NAS QNAP utilisé en SAN IP?

Erick.

Link to post
Share on other sites

Bonjour,

Normalement, C'est vendu pour....

Mais effectivement j'ai un doute par rapport au fonctionnement mais d'après cet article: http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?lang=en&cc=us&taskId=120&prodSeriesId=3811492&prodTypeId=329290&objectID=c01783861 c'est maintenant supporté.

J'ai lu pas mal d'article sur des bugs avec les initiateurs iscsi matériesl et le très peu d'intérêt par rapport au initiateur logiciel avec jumbo frame et aux baies de stockage utilisées.

Pour le coup, j'ai l'impression que c'est le stockage Qnap qui rend l'âme (overhead) lors de gros accès.

Erick.

Link to post
Share on other sites

Bonjour,

Le mieux est d'ouvrir une demande de support ...

donnez votre modèle, le firmware (pour Iscsi ... il vaut mieux être à jour), l'initiateur ...

Si vous utilisez tcpip ... la régulation se ferra au niveau réseau ... par la pile I.P.

De même les Jumbo Frame (rappel TOUS les matériels connectés sur le sous-réseau physique DOIVENT le supporter ET être configuré avec les MÊMES valeurs de Jumbo ... )

Le problème récurrent est la mauvaise (plutôt la simpliste) gestion de la pile I.P. par les matériels "embeded" donc les initiateurs matériels ...

Si le problème venait (relativement facile à voir) d'une non réponse du QNAP en cas de surcharge ... un "renice" de la tache serveur ... pourrait aider ...

Avez-vous regardé dans le log du Qnap ... car Qnap a inclus iscsi_logd ...

/etc/init.d/klogd.sh dump

Philippe.

Link to post
Share on other sites

Je suis "issue" du monde ( fabuleux ? ) VMware, est ne connais pas trop Hyper-V mais ... Allez savoir pourquoi ... ces hypervizers ne sont pas compatible avec les HW iSCSI et un MTU a 9000???? Ou est leurs problèmes???

Dans le monde VMware on a une KB pour sa. Peut etre MS aussi?

Link to post
Share on other sites

Le support QNAP m'a donnée des indicateurs de configuration:

""""

I remembered that I had a similar experience without final solution from another user with HP Proliant G7 once.

The server that I found is HP Prolint DL 380 G6 (NIC: HP NC382i) is in our Lab.

Here are several hints and will assist you to improve the connection quality.

1. Turbo NAS:

Update the firmware to latest version. (you have already done!)

Try not to use jumbo frame in Network configuration. Set the MTU to 1500 instead of 9000.

Disable Network Port Trunking

Use specific network speed instead of auto-negotiation in TCP/IP setting.

Try to assign a specific NIC for iSCSI service.

2. Windows OS:

Update the Windows OS and patch the Windows Hot Fix.

Use the latest MS initiator. (You tried without problem already!)

Use the latest driver of your server NIC.

Disable the jumbo frame setting of your server NIC in Advanced properties.

Enable flow control of your server NIC in Advanced properties.

Increasing the Receive buffers (descriptors) on your server NIC(s) in Advanced properties

Adjust Microsoft initiator Driver time settings in the registry:

Key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E97B-E325-11CE-BFC1-08002BE10318}\Instance Number>\Parameters

Where the <Instance Number> is the MS software initiator index. Just browse the DriverDesc value under it to see if it is "MicrosoftiSCSI initiator".

- MaxRequestHoldTime

Default is 60, please change to 600 in decimal format (00000258 in hexadecimal).

- SRBTimeoutDelta

- Default is 15, please change to 180 in decimal format (000000B4 in hexadecimal).

- Restart the Window host to active these new settings

- Adjust Microsoft Disk Driver Timeout settings in the registry:

Key: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Disk- TimeOutValue

Edit or add the TimeOutValue entry to set it to 180 in decimal format (000000B4 in hexadecimal). To edit the value for the TimeOutValue entry if it already exists, double-click the entry, enter the new value, and click OK.

To add the TimeOutValue entry if it does not yet exist, right-click anywhere in the list of values, and click New > DWORD value. Name the new value TimeOutValue in decimal, and then double-click it to edit the setting.

- Restart the Window host to active these new settings.

3. Switch:

Use VLAN to separate iSCSI protocol with other protocol.

Enable flow control on the switch.

Enable or disable jumbo frame settings according to the Jumbo Frames configurations on the Turbo NAS.

Set more buffer for the port which is used by Turbo NAS.

Use specific network connection speed instead of auto-negotiation.""

Rien n'y fait :)

J'ai toujours des erreurs de conflits d'écriture sur les LUNs.

Dans les logs du QNAP ça me donne:

""WRITE Conflict for unregistered nexus iqn.1991-05.com.microsoft:....local CDB: 0x2a to Write Exclusive Access, Registrants Only reservation”

J'ai essayé en passant le MPIO de roundrobin à failover avec le même résultat...

J'attends un retour de QNAP.

Link to post
Share on other sites

Bonsoir,

Bon finalement, le support Qnap admet ne pas supporter l'initiateur matériel, du moins pour HP, car le technicien m'a confié que cela était supporté pour un constructeur mais ne m'a pas dit lequel.....

Donc je passe avec l'initiateur Microsoft :'(

Au moins cela marche nickel....

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...