Jump to content
  • 0

Problème De Volume Raid


Go to solution Solved by carex,

Question

Bonsoir,

 

Nas et disques achetés cet été neufs. Les disques sont des greens j'ai désactivé le parquage des têtes.

Depuis un mois, j'ai des erreurs lors de mes tests rapides ou complets sur 3 de mes disques (Disk 2, 3 et 4).

Je reçois par mail un message du type :

Server Name: QNAP
IP Address: 192.168.0.2
Date/Time: 07/01/2013 02:01:49
Level:  Error
[HDD SMART] HDD 3 Rapid Test result: Completed: read failure.

Du coup, depuis l'interface j'avais lancé des scans sur les 3 disques en question et ai eu pour résultat : [Drive 2] Bad Blocks Scan completed. 21 bad block(s) found.

Les états SMART des disques restaient en orange.

 

Hier en passant devant mon NAS, je me suis dit que débrancher et rebrancher un disque, reconstruirai mon RAID et résoudrai peut être mon soucis.

Je débranche et rebranche le disque 2, depuis l'interface je vois que mon volume est en reconstruction... Je laisse tourner.

Ce matin au réveil, j'ai reçu 3 mails pendant la nuit :

A 6h30 : [RAID5 Disk Volume: Drive 1 2 3 4] Error occurred while accessing Drive 3.

A 6h37 : [RAID5 Disk Volume: Drive 1 2 3 4] Error occurred while accessing the devices of the volume in degraded mode.

A 6h44 : Re-launch process [nmbd].

 

Aujourd'hui je me rend compte, que je n'accéde plus à mes partages, il a perdu son nom.

J'accéde à l'interface via son IP et je n'arrive plus à m'authentifier.

J'ai tenté de modifier le mot de passe via l'écran physique du NAS, mais sans succés.

Je n'ose pas le rebooter, ayant peur de faire pire que mieux...

 

Vers quelles manips dois-je me diriger pour récupérer l'accés au NAS et aux données qu'il contient ? Merci d'avance

Link to post
Share on other sites

16 answers to this question

Recommended Posts

  • 0
  • Solution

Je m'en suis sorti !

 

J'ai tenté d'arrêter la reconstruction du RAID via la commande idle dans le sync_action en shell, mais il était tellement planté que même ça il a pas su le faire.

Donc je l'ai arreté via le bouton power, enlevé le disque 2, pour ne pas que la reconstruction s'effectue, et redémarré le bestio.

Il a redémarré en mode dégradé lecture seule.

 

Mes données sont en train d'être sauvegardées sur mon autre NAS.

Merci pour votre aide

Link to post
Share on other sites
  • 0

Précision sur l'état des voyants,

Status : clignote rouge / vert

Voyant des disques 1 et 2 au vert (apparemment le voyant du disque 2 est repassé au vert suite à la manip d'hier soir)

Voyant des disques 3 et 4 , toujours au rouge

 

Qfinder le détecte bien sur le réseau ( a première vu il a bien gardé son nom et toute sa conf réseau )

Je n'arrive pas à m'authentifier, mot de passe erroné. J'affiche les détails, réessaye de m'authentifier et la il tourne dans le vide...

Link to post
Share on other sites
  • 0

Vous pouvez faire un reset court à l'arrière du nas pas plus de trois secondes. Lisez la doc du nas si vous ne savez pas comment faire.

 

Cela va réinitialiser le mot de passe admin par défaut ainsi que les paramètres réseaux. Après vous pourrez entrer sur le nas...

 

Si le disque 2 est revenu au vert alors c'est une bonne nouvelle, aussi je vous conseille de faire la même chose avec le troisième puis quand celui-ci sera revenu au vert...vous pourrez faire de même avec le quatrième. La reconstruction prend du temps (plusieurs heures dépendant de la taille des disques) alors il ne faut pas éteindre le nas ni sauter d'étape.

 

Je pense que vos disques sont bons mais je ne puis vous l'assurer. Trois disques en même temps cela ressemble plus à une défaillance en cascade...baisse de courant ou coupure brusque.

Link to post
Share on other sites
  • 0

Bon en fait j'accéde à l'interface !!

Il est très lent, aucuns services n'a apparemment démarré. Dans le menu, Gestion de volume et Outil de gestion RAID, n'affichent rien.

 

Il est ondulé, ça m'embêterai que tout ça soit lié à un problème éléctrique.

 

Je tenterais bien de le redémarrer... (Les voyants des disques 3 et 4 restent rouges fixes)

Link to post
Share on other sites
  • 0

Je récupére un peu de performance au niveau de la navigation dans l'interface web.

J'accéde enfin à l'Outil de gestion RAID, et il est reconstruction à 89% et cela depuis 27h20min !!

 

Wait and see... et on croise les doigts !

Link to post
Share on other sites
  • 0

Il est toujours bloqué à 89% de reconstruction, depuis plus de 40h...

 

Je tente d'accéder au gestionnaire de fichiers web, pour sauvegarder les dernières données sensibles (l'accès en FTP ne fonctionne pas)

 

Je suis à cours d'idées...

 

Reste toujours la possibilité de rebooter, mais bon...

Link to post
Share on other sites
  • 0

Probablement que c'est très très lent parce que le disque dur n°3 est en piteux état et que le processus de reconstruction essuie depuis des heures des échecs de lecture à chaque fois qu'il a besoin de lire certains secteurs sur ce disque.

 

Par ailleurs, je ne comprends pas pourquoi vous avez choisi de retirer le disque n°2 plutôt que le n°3, alors que le NAS vous alertait que c'était ce dernier qui devient inquiétant ?

Tant qu'à forcer une volume RAID à passer en mode dégradé, autant le faire en retirant le disque qui semble faiblard, non ?

 

Avez-vous un backup des données sensibles stockés sur ce volume RAID ?

Link to post
Share on other sites
  • 0

J'ai appris à mes dépends qu'il ne faut pas laisser trainer le type d'alerte que vous avez depuis un mois : 3 disques sur 4 qui remontent des erreurs aux tests SMART, c'est 2 de trop pour un RAID 5.

Avec un peu de chance, seul (le disque 3, je suppute) un est vraiment dans un état ne permettant plus de l'utiliser dans le RAID et les autres n'ont pas encore de problèmes non contournables, en utilisant le stock de secteurs de secours par exemple (cas du disque 2, je dirais).

Mais il est urgent, une fois le volume à nouveau accessible au moins en lecture, de :

- faire un backup si ce n'est pas fait 

- procéder au remplacement des 3 disques durs défaillants, en commençant par le plus gravement atteint (le trois, d'après moi) : attention, la procédure nécessite de le faire un par un en passant par l'interface de gestion RAID, sélectionner le volume, sélectionner le disque à remplacer, valider "remplacer", retirer, attendre le bip de confirmation, insérer le nouveau, attendre le bip de confirmation, attendre la (lente, toujours lence) reconstruction à partir des données des 3 autres disques. Une fois fait, recommencer pour les 2 autres disques.

 

Bon courage.

Link to post
Share on other sites
  • 0

J'ai choisis de retirer le disque 2 car c'est le 1er qui était en voyant rouge.

Rapport d'erreur sur les disques 2 et 3 puis 2 semaines plus tard le disque 4.

Les 3 disques étaient dans le même état, bad blocks et read failure

[Drive 2] Bad Blocks Scan completed. 21 bad block(s) found.
[HDD SMART] HDD 2 Full Test result: Completed: read failure.

Je n'ai pas de backup des données sensibles. Pas pris le temps de la mettre en place, et sur le coup ça continué à tourner je ne me suis pas senti inquiété

 

Par contre le disque je l'ai débranché physiquement du NAS, sans me connecter au préalable à l'interface web pour le retirer proprement.

 

J'ai bien peur que le volume ne soit plus jamais accessible, 89% de la reconstruction, éxécution depuis plus de 48h, est ce aussi long?

Dois je attendre? Tenter un reboot? Redébrancher le disque 2?

Je ne comprends pas pourquoi je n'accéde plus à rien, avec un disque en moins ça devrait continué à fonctionner...

 

Merci à tous pour votre aide et vos réponses !

Link to post
Share on other sites
  • 0

Effectivement il semble tourner en boucle comme le dit byte_order.

 

Si vous avez des services qui tournent en arrière plan (qpkg par exemple) il faut les arrêter pour ne pas trop solliciter les disques pendant la reconstruction puis attendez encore 24 heures...peut-être un miracle ?

 

Pensez entretemps à une solution de sauvegarde pour vos données en usb par exemple, vous en aurez peut-être besoin bientôt.

 

Est-ce que vos disques font partis de la liste de Qnap qui ont des problèmes avec le raid ?

Link to post
Share on other sites
  • 0

Effectivement il semble tourner en boucle... Je n'ai plus accès à l'interface web aujourd'hui.

 

Mes disques sont des Western Digital Caviar Green 3 To SATA 64 Mo Serial ATA 6Gb/s - WD30EZRX, ils apparaissent dans la liste non officielles, à la base je les avais acheté pour mon NAS Vehotech.

 

Un pote qui connait Linux est passé, on s'est co en SSH, et avons affiché le rapport de la reconstruction. (2ans de reconstruction si on fait le calcul)

post-2127-0-97594600-1359671728_thumb.jp

 

 

Il a aussi remarqué que, la commande TOP renvoie une forte utilisation du NAS, apparemment très très mauvaise !!

post-2127-0-16023200-1359672405_thumb.jp

 

Je vais encore attendre 2 jours, mais si je pars du principe qu'il est bloqué, il faut que je pense à une solution ; Il faut que j'arrête la reconstruction

Pour cela, je reboot simplement? il devrait reprendre la construction si je dis pas de bêtises

Je réenlève le disque 2? espérant passer en mode dégradé et ainsi pouvoir récup mes données, à voir si il ne faudra pas reboo

Link to post
Share on other sites
  • 0

Bonsoir

 

vos disques sont effectivement non supportés. Cela explique le problème. Il vaut toujours mieux se fier à la liste officielle parce que 'l'autre liste' est à risque.

 

Le cas échéant vous pourrez récupérer vos vieux disques comme sauvegarde de secours dans l'avenir...mais attendons...le patient vit encore.

 

Quant au redémarrage c'est à éviter, si vous désirez retirer les disques faites le à chaud à partir de la console admin selon la documentation de Qnap et il est toujours préférable de formater le disque avant de le remettre en place (mais il ne faut pas oublier ici qu'il vous reste la moitié de votre grappe...?)

 

Aussi je vous conseille, si vos données sont vraiment importantes (si vous êtes un professionnel ou avez une entreprise, je ne sais trop...je spécule) de demander à une firme externe spécialisée dans le domaine de vous aider, mais ça coûte cher...il faut donc que ce soit important.

 

PS: pour vos futurs disques je vous conseille l'achat chez deux fabricants différents, donc 2 d'une marque et 2 autres d'une autre marque. Vous augmenterez ainsi la fiabilité de la grappe.

 

Bonne chance carex

j'aurais bien aimé vous aider plus...

Link to post
Share on other sites
  • 0

La console ? L'interface web vous voulez dire? Si c'est le cas, je n'y ai plus accès... Donc la seule façon sera de le retirer à l'arrache.

 

C'est la reconstruction qui a fait entièrement planté mon NAS, je veux la stopper, pour repartir sur mon NAS en mode dégradé, je pourrai ainsi accéder à mes données en toute logique.

Comment arrête t'on une reconstruction en SSH svp ? Vous pouvez m'aider si vous connaissez la bonne commande :)

 

Il me semblait avoir compris qu'il valait mieux privilégier des disques de même marque et même modèle.

Link to post
Share on other sites
  • 0

Bonjour carex

 

oui la console ou bien la page admin du nas, c'est la même chose.

 

mais puisque vous n'y avez plus accès, je ne sais plus trop quoi vous recommander. Comprenez que je ne suis qu'un bénévole et je ne voudrais pas être la cause d'une catastrophe pour vous. Aussi je me demande si le support de qnap ne pourrait pas faire une tentative à distance pour vous...ils sont les plus qualifiés mais ce n'est pas garanti non plus. Ou un ami qui s'y connait avec le nas...

 

Quand un problème de raid survient, (1 disque défaillant)  comme je l'ai dit précédemment il faut retirer le disque à chaud dans l'administration du nas, il y a une option pour cela, puis retirer le disque du nas (faire une vérification des secteurs sur un pc... test smart et tout le tralala) et si tout est beau le formaté sur un pc, pour ensuite le remettre sur le nas. Ainsi le nas va faire son travail comme si vous aviez mis un disque neuf et la reconstruction va se faire sans résidus, si je peut me permettre ce terme.

 

Quand aux disques ce qui est important de retenir c'est;

 

1-la même capacité

2-la même vitesse de rotation des disques

3-Qnap approuve ces disques officiellement

 

Si je vous ai donné ce conseil (achat chez deux fabricants différents) c'est tout simplement pour éviter de vous retrouver avec un lot de disques qui auront les même pièces, donc qui risquent plus de tomber en panne en même temps dans le futur. Mais si vous faites des sauvegardes régulières...pas de problème pour le même lot de disques.

 

Bien sûr il n'y a aucune littérature scientifique (à ma connaissance) qui dit qu'un lot similaire de disques du même fabricant tombe en panne le même jour à la même heure. Cela reste donc personnel à chacun.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...