Jump to content
  • 0

Données Perdues .... Ou Pas .... Au Secours


Guest

Question

Bonjour

 

Je rencontre actuellement quelques problèmes avec mon Qnap TS-410

 

J'avais pris du retard dans les mises à jour. Je pense que j'étais en 3.7. Lors de ma tentative de mise à jour, celle-ci bloqué systématiquement à 10% et le nas n'étais plus accessible depuis le raccourci réseau créé sur mon PC. Je l'ai donc recommencée à plusieurs reprises .... comble de malchance lors d'une tentative j'ai eu une belle panne de courant.

Les disques n'étaient plus accessible du tout.

Pour information j'utilisais les 4 disques de 1To en mode "volume disque d'entrelacement" soit 4 disque en 1 volume. 

 

J'ai refait une installe sur un disque vierge. pour vérifier que le nas fonctionnait toujours et j'en ai profité pour mettre à jour le firmware en 4.0.1.

j'ai ensuite remis, à chaud , les disque originaux dans leur ordre initial.

Dans un premier temps il trouvait les disques mais il n'étaient pas montés. Maintenant je démarre bien en 4.0.1 et les disques sont repris dans "gestionnaire de stockage" comme "volume disque d'entrelacement : lecteur 1 2 3 4"  

 

 Il m'indique toutefois que les disques sont plein. ce qui est bien possible vu les transfert que je faisait avant la panne de courant. 

 

Mon problème c'est que aucun fichier n'est visible. 

Je ne retrouve même pas les répertoires qui existait dans l'ancienne version. soit Qmultimedia/video/

 

il n'y a rien dans aucun répertoire 

dans le log il y a un message "Folders (Usb, Multimedia, Download) for default network shares do not exist. Restroe default network share or format your disk volume"

 

En console dans le répertoire share je trouve un tas de répertoire

Download@     HDA_DATA/   HDB_DATA/   .HDC_DATA/     HDD_DATA/..... jusque HDZ_DATA/

MDO_DATA/     Qsync/           Multimedia@    Public@      external/      Recording@         Usb@        Web@

 

Y a t'il un moyen de retrouver mes répertoires et mes données ? 

Faut il que je réinstalle un firmware plus ancien pour cela ? Est ce possible de downgrader le firmware ?

Y a t'il une commande console à utiliser ? 

 

Est ce que tout est perdu et que je n'ai plus qu'a reformater ?

 

Merci de votre aide

 

 

 

 

 

 

 

 

 

 

 

Link to comment
Share on other sites

7 answers to this question

Recommended Posts

  • 0

Votre erreur a été de refaire une installation "complète" et de réinsérer vos disques à chaud... En effectuant une recherche sur ce forum (ok c'est un peu chercher une aiguille dans une botte de foin, d'où ma demande au service modération plus bas) vous auriez trouvé la marche à suivre pour éviter ces déboires.

 

Pour que les mises à jour se passent bien :

Philippe à écrit :

 


EN PREMIER : un reboot (si ce n'est fait)

EN SECOND : réinstaller le même firmware (update du même fichier) en ayant arrêté AVANT les principaux QPKG dont twonky ...

 

Si il y a encore un problème passez par Qfinder pour faire votre mise à jour.

 

Pas de panique si vous voulez récupérer vos données sans vous ruiner : http://www.stellarinfo.com/fr/

 

Si vous avez déjà sauvegardé vos données alors oui vous pouvez formater...

 

Note utile pour les modérateurs : N'ayant pas les droits pour créer un tuto, un modérateur pourrait-il en créer un, pour une meilleure clareté et une meilleur lisibilité du forum, en rappelant les procédures d'urgences à effectuer en cas de problème HDD, de mises à jour, de perte d'accès au NAS, afin que les nouveaux utilisateurs puissent trouver rapidement la solution ce qui éviterai les nombreux doublons sur ces sujets récurrents?

Merci à vous.

Link to comment
Share on other sites

  • 0

Bonjour,

 

Avant même d'aller plus loin ...

Si "volume disque d'entrelacement" ... veut dire Raid0 ... vous avez pris de "gros" risques ... il n'y a (hors serveur de contenu "sans valeur" ou multiple duplication de serveurs) AUCUN avantage au Raid0 ... que des inconvénients ... dont la perte assurée des données (hors récupération ... chère et approximative) des données ... tout simplement par ce que celle-ci sont découpés par blocs aléatoirement mis sur tous les disques ... cela accélère la lecture et enlève TOUTE sécurité des données ... donc a usage (beaucoup de lecteurs (sinon le gain est peannuts) et aucune valeur pour les données)

 

Savez-vous vous connecter en ssh ou telnet et regarder si vos données sont toujours visible en mode console .... car

si OUI ... il suffira de recréer les partages en sélectionnant le chemin d’accès au lieu de créer le répertoire cible ... puis de remettre les droits ...

de même pour les partages par défaut ... il y a un petit bouton (dans partage) ... pour les recréer ...

... et encore plus simple ... si vous avez sauvegardé la configuration ... AVANT ...

si NON ... hum! j'ai bien peur que vous ayez à suivre les conseils de Yann. avec un taux de chance de récpération très faible

 

Philippe.

NB il y a aussi des logiciels gratuits sous Mac, Linux et Windows comme R-studio (R-Tools)

Link to comment
Share on other sites

  • 0


NB il y a aussi des logiciels gratuits sous Mac, Linux et Windows comme R-studio (R-Tools)

 

Merci beaucoup Philippe, je ne connaissais pas du tout. Je me permets de mettre le lien qui va bien : http://www.r-tt.com/fr/

 

NB et j'insiste pour plus de praticité et éviter les sujets à répétition :

 

N'ayant pas les droits pour créer un tuto, un modérateur pourrait-il en créer un, pour une meilleure clareté et une meilleur lisibilité du forum, en rappelant les procédures d'urgences à effectuer en cas de problème HDD, de mises à jour, de perte d'accès au NAS, afin que les nouveaux utilisateurs puissent trouver rapidement la solution ce qui éviterai les nombreux doublons sur ces sujets récurrents?

Merci à vous.

Link to comment
Share on other sites

  • 0

Bonjour

 

MErci pour vos réposnes.

 

Tous cela n'est pas très bon mais c'est ma faute j'ai pris des risques .... je dois assumer

LEs données ne sont pas primordiale ce ne sont "que" des films et des séries.... mais bon il n'est jamais agréable de perdre autant de données

 

en mode console tout ce que j'ai c'est ça

 

En console dans le répertoire share je trouve un tas de répertoire

Download@     HDA_DATA/   HDB_DATA/   .HDC_DATA/     HDD_DATA/..... jusque HDZ_DATA/

MDO_DATA/     Qsync/           Multimedia@    Public@      external/      Recording@         Usb@        Web@

 

dasn ma grande ignorance je me disais que peut être il y avais un moyen de reconstruire les données à partir des répertoires HDA_DATA à HDZ_DATA

 

l'installation que j'ai refaite a été faite sur un nouveau disque et ensuite j'ai enlevé à chaud ce disque et remis les anciens disque..... cela n'étais donc pas une bonne idée ?

Il fallait impérativement réinstaller le même firmware ?

j'aime comprendre mes erreurs.

 

je tenterais l'utilisation des soft proposés ce soir .... sinon reformatage en vue ....

 

MErci

Link to comment
Share on other sites

  • 0

Oui, lorsque vous avez une erreur lors de l'installation d'un firmware, mieux vaut réessayer avec le même.

 

Je vous recommande vivement d'effectuer vos backups via un HDD externe (USB), c'est plus pratique pour la restauration des données dans un cas de figure comme vous rencontrez actuellement.

 

Pour l'utilisation des softs, je connais les solutions de Stellar et j'ai pu récupérer de nombreuses données même après un formatage (après un formatage c'est un peu le bazard pour faire le tri entre les anciens fichiers et les nouveaux), seul un formatage bas niveau pourra supprimer les données définitivement (sauf via méthode de laboratoire).

 

Toutefois et connaissant un petit peu notre ami Philippe, s'il vous conseille R-TT Tools, alors vous puvez lui faire confiance, je n'ai pas encore eu le temps de tester mais je n'y manquerai pas de le faire si je devais connâitre ce genre de malheur.

 

Quand à une reconstruction, je vous conseille de récupérer vos données, de les reconstruire en Raid0 puis de sauvegarder vos données (musique, films,documents) sur un HDD externe. Une fois cette mission accomplie, faites une nouvelle réinstallation avec le dernier firmware avec formatage de vos disques en Raid 5 (vous perdez 1 HDD) ou 6 (vous en perdez 2) mais oubliez absolument le raid0 comme vous l'a conseilleé Philippe! (En général 2 Baies : Raid1, 4Baies : Raid5)

 

Voici quelques infos sur les Raids :

 

http://fr.wikipedia.org/wiki/RAID_%28informatique%29

 

http://www.concordance-informatique.com/blog/2010/11/quelle-architecture-raid-choisir/

 

http://www.commentcamarche.net/contents/996-protection-les-systemes-raid

 

Et comme le dit la signature de Philippe :

 

 

 

Le Raid N'EST PAS un backup (proverbe Qnapien)
Link to comment
Share on other sites

  • 0

Bonjour,

 

Dans votre cas les données sont dans /share/MD0_DATA/ ... qui est le point de montage du Raid0 c'est là qu'il faut chercher ...

 

Philippe.

NB il y a un chapitre de la documentation qui s'appelle migration ... c'est d'un QNAP à un autre (nouveau) ... mais cela s'applique aussi a une manipulation comme celle que vous avez essayé ...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...